Forcer l’installation d’extensions Firefox non-compatibles

Votre Firefox vient de ce mettre à jour et "oh malheur", votre extension favorite n’est plus compatible. Vous avez désinstallé puis réinstallé cette extension sans succès. Pour contourner le problème et forcer l’installation de ces extensions officiellement déclarées non compatibles, voici une petite astuce qui désactivera la vérification de compatibilité à l’installation de ces dernières (valable pour Firefox 2 et 3) :

Ouvrez Firefox, tapez ‘about:config‘ dans la barre d’adresse.
Faites un clic droit puis “Nouveau -> Boolean“. Entrez “extensions.checkUpdateSecurity” dans la boîte de dialogue et validez par OK. Positionnez la valeur a “false“.
Faites de même en créant une entrée “extensions.checkCompatibility” toujours a “false“.

A utiliser à vos risques et périls certaines extensions étant réellement incompatibles.

Personnellement cette astuce m’a permis de faire fonctionner sur FF2 une extension réservée à FF3 (SearchWP) et certaines extensions dont les versions ne sont pas encore compatibles avec FF3b5 (Webmail Notifier, FEBE, CLEO…). Et vous quelle extension cette astuce vous a t’elle permis d’installer?

10 réflexions au sujet de « Forcer l’installation d’extensions Firefox non-compatibles »

  1. Superbe. Utilisateur de la version de dév’ de Firefox, mon Adblock chéri n’était plus compatible. Mais ça remarche avec ton astuce =) .

  2. super info qui aurait pu marche malheureusement pas pour moi

    en version 3.6.3 elle est inutile les boules

  3. magnifique !

    les extensions suivante marchent grâce à vous :

    – Auto Copy

    – Sleather

    – Redirect Remover

    Merci énormément ^^

  4. Perso, je refait l’extension pour qu’elle soit compatible.
    Ainsi l’extension CVIEW est désormais utilisable avec FF3 !

  5. Merci pour cette astuce, pour ma part j’ai fait fonctionne minimizetotray
    @+

  6. Merci papoo pour le compliment, c’est très sympa. Je suis également abonné à ton flux, car je privilégie de plus en plus les applis portables. Bonne continuation sur ton excellent blog et @+ :)

  7. Merci de ces précisions Gabuzo38. je pense à peu prêt la même chose que toi vis à vis de addons.mozilla.org. J’en profite pour te féliciter de la qualité de ton blog, je suis même abonné :).

  8. Bonjour !

    Pour l’expression "extensions.checkUpdateSecurity", cela ne concerne que Firefox 3, et pour "extensions.checkCompatibility" (qui gère la compatibilité au niveau du MaxVersion) il est possible, si l’on ne veut pas toucher à "about:config", d’utiliser Nightly Tester Tools, voire MTLI, qui se chargera d’ignorer le paramètre de compatibilité . Sinon, y’a toujours la bonne vieille méthode manuelle de bump du fichier rdf ! (Tout ceci à faire bien sûr dans un profil dédié).

    Quant à la la nouvelle présentation d’AMO, elle est sûrement très bien pour l’utilisateur courant (qui sera informé immédiatement de la possibilité d’installer le thème ou l’extension concernée), mais je la considère comme régressive pour les développeurs et/ou utilisateurs avancés (plus de mention des min/Version et max/Version, même plus de possibilité de DL si la version de FF ou du fichier sont pas compatibles, etc..).

  9. Merci pour ton feedback supergex!
    Effectivement le site addons.mozilla.org détecte la version de firefox et empêche le téléchargement des extensions non compatibles. Généralement on peut contourner le problème en allant sur le site officiel de l’extension pour la télécharger.

  10. Salut papoo.

    J’ai un petit soucis avec ton astuce pour firefox.
    En fait pour qu’elle fonctionne, il faut déjà avoir le fichier *.xpi quelque part, car ça n’empèche le fait que le téléchargement des extensions non compatible est bloqué !? (par exemple sur addons.mozilla.org)

    Il faudrait peut-être que tu rajoutes qu’il faut au préalable télécharger le xpi avec par exemple l’extension DownThemAll.

    Sinon merci beaucoup pour ton travail, bon boulot !

    SuperGex, ancien VCL, toujours fauché !

Laisser un commentaire